how to stop Multiple Monitor Screens from repositioning after waking from sleep mode

Budget101 Discussion List Archives Budget101 Discussion List how to stop Multiple Monitor Screens from repositioning after waking from sleep mode

  • This topic is empty.
Viewing 0 reply threads
  • Author
    Posts
    • #602448
      Liss

      If you have multiple monitors and you’re running win10, it’s likely you’ve encountered a very frustrating error. Whenever the computer goes to sleep, when it “awakens” the screen positions have moved. The primary screen and all the icons move to another monitor. At first I thought this was due to my Nvidia graphics card.  I did a few searches and realized that it has very little to do with your graphics card or with your monitor brand. I’m using 2 ASUS monitors and 2 acer monitors.

      The issue only started appearing once I installed the 2 latest monitors (replacing 2 older ones).

      Windows 10 appears to keep a history of all the monitors it encounters during its lifetime. This includes the basic monitor support during the OS install. By enabling “Show hidden devices” in Device Manager, you will be able to see all the monitors connected to your system.

      How to Stop Monitor Screens from Repositioning after waking from Sleep Mode

      Start the Control Panel as Administrator:

      1.  Start Control Panel –> Device Manager
      2.  Select View –> Show hidden devices
      3.  Expand Computer –> Monitors

      stop screen repositioning after sleep

      When you expand the Monitors you will see your current monitor (highlighted) and all the disconnected monitors (greyed out).   You may see monitors with “non-PNP” and “PNP” listed as well.  It’s likely these monitor listings are aliases to your current monitor (at a lower resolution) before Windows installed drivers for it.

      Remove (uninstall) ALL of the greyed out monitors.

      1. Right-click on these monitors and select uninstall.  Keep only the highlighted monitor you are currently using.
      2. Uninstall all greyed out monitors (even non-PNP and PNP monitors)
      3. Reboot your system.

      After doing this my windows no longer resize or lose position after my monitors wake from the sleep setting.  

      To quickly test to see if your monitors are fixed, you can temporarily setting your monitor sleep time to 1 minute.

      Simply go to: Settings –> System –> Power & Sleep –> Screen [1 minute]
      sleep mode multiple monitors

      Attachments:
      You must be logged in to view attached files.
Viewing 0 reply threads
  • You must be logged in to reply to this topic.

Budget101 Discussion List Archives Budget101 Discussion List how to stop Multiple Monitor Screens from repositioning after waking from sleep mode